#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=(?:1|^)(?!0{6})0{0,4})0"
Local $sString = "11110000111100000000111100001111000000" & @CRLF & _
"" & @CRLF & _
"1111....1111000000001111....1111000000"
Local $sSubst = "."
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)