import Foundation
let pattern = #"(?<=(?:1|^)(?!0{6})0{0,4})0"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
11110000111100000000111100001111000000
1111....1111000000001111....1111000000
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"."#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)