using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=(?:1|^)(?!0{6})0{0,4})0";
string substitution = @".";
string input = @"11110000111100000000111100001111000000
1111....1111000000001111....1111000000";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}