use strict;
my $str = '11110000111100000000111100001111000000
1111....1111000000001111....1111000000';
my $regex = qr/(?<=(?:1|^)(?!0{6})0{0,4})0/mp;
my $subst = '.';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";