re = /(?<=(?:1|^)(?!0{6})0{0,4})0/m
str = '11110000111100000000111100001111000000
1111....1111000000001111....1111000000'
subst = '.'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result