#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.+?)(?:\(.+?\))"
Local $sString = "A one text. (SOME:TICKER)Another one may (GGWP:CS)Something new (HERE:NOT)"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)