$re = '/(.+?)(?:\(.+?\))/m';
$str = 'A one text. (SOME:TICKER)Another one may (GGWP:CS)Something new (HERE:NOT)';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;