use strict;
my $str = 'A one text. (SOME:TICKER)Another one may (GGWP:CS)Something new (HERE:NOT)';
my $regex = qr/(.+?)(?:\(.+?\))/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";