using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.+?)(?:\(.+?\))";
string substitution = @"$1";
string input = @"A one text. (SOME:TICKER)Another one may (GGWP:CS)Something new (HERE:NOT)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}