package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.+?)(?:\(.+?\))`)
var str = `A one text. (SOME:TICKER)Another one may (GGWP:CS)Something new (HERE:NOT)`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}