import Foundation
let pattern = #"(.+?)(?:\(.+?\))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"A one text. (SOME:TICKER)Another one may (GGWP:CS)Something new (HERE:NOT)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)