#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https?:\/\/(.*:.*@)?[^\.:]+(\.[^\.:]+){1,2}(\:\d+)?[^:]+$"
Local $sString = "http://io:tu@was.as.ds:12/asd" & @CRLF & _
"http://was.as.ds:12/asd" & @CRLF & _
"http://io:tu@was.as.ds/asd" & @CRLF & _
"http://io:tu@was.as.com" & @CRLF & _
"https://io:tu@was.as.ds/asd" & @CRLF & _
"httpp://io:tu@was.as.ds/asd" & @CRLF & _
"http:/io:tu@was.as.ds/asd" & @CRLF & _
"http://io:tu#was.as.ds/asd" & @CRLF & _
"http://io:tu@was.ds" & @CRLF & _
"https://was.ds" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")