const regex = /^https?:\/\/(.*:.*@)?[^\.:]+(\.[^\.:]+){1,2}(\:\d+)?[^:]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https?:\\\/\\\/(.*:.*@)?[^\\.:]+(\\.[^\\.:]+){1,2}(\\:\\d+)?[^:]+$', 'gm')
const str = `http://io:tu@was.as.ds:12/asd
http://was.as.ds:12/asd
http://io:tu@was.as.ds/asd
http://io:tu@was.as.com
https://io:tu@was.as.ds/asd
httpp://io:tu@was.as.ds/asd
http:/io:tu@was.as.ds/asd
http://io:tu#was.as.ds/asd
http://io:tu@was.ds
https://was.ds
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}