re = /^https?:\/\/(.*:.*@)?[^\.:]+(\.[^\.:]+){1,2}(\:\d+)?[^:]+$/m
str = 'http://io:tu@was.as.ds:12/asd
http://was.as.ds:12/asd
http://io:tu@was.as.ds/asd
http://io:tu@was.as.com
https://io:tu@was.as.ds/asd
httpp://io:tu@was.as.ds/asd
http:/io:tu@was.as.ds/asd
http://io:tu#was.as.ds/asd
http://io:tu@was.ds
https://was.ds
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end