#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^<>]*((<\/?(w|phr|evHL)[^<>]*>)*([^<>]*))*$"
Local $sString = "toto<phr start="1583554989500" end="1583554992040" confidence="0.22"><w s="1583554989500" d="60" c="0.22">Hey</w> <w s="1583554990920" d="390" c="0.18">mama</w> <w s="1583554991770" d="270" c="0.27"><evHL>poll</evHL></w> </phr>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")