use strict;
my $str = 'toto<phr start="1583554989500" end="1583554992040" confidence="0.22"><w s="1583554989500" d="60" c="0.22">Hey</w> <w s="1583554990920" d="390" c="0.18">mama</w> <w s="1583554991770" d="270" c="0.27"><evHL>poll</evHL></w> </phr>';
my $regex = qr/^[^<>]*((<\/?(w|phr|evHL)[^<>]*>)*([^<>]*))*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}