import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^<>]*((<\\/?(w|phr|evHL)[^<>]*>)*([^<>]*))*$";
final String string = "toto<phr start=\"1583554989500\" end=\"1583554992040\" confidence=\"0.22\"><w s=\"1583554989500\" d=\"60\" c=\"0.22\">Hey</w> <w s=\"1583554990920\" d=\"390\" c=\"0.18\">mama</w> <w s=\"1583554991770\" d=\"270\" c=\"0.27\"><evHL>poll</evHL></w> </phr>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}