// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^<>]*((<\/?(w|phr|evHL)[^<>]*>)*([^<>]*))*$").unwrap();
let string = "toto<phr start=\"1583554989500\" end=\"1583554992040\" confidence=\"0.22\"><w s=\"1583554989500\" d=\"60\" c=\"0.22\">Hey</w> <w s=\"1583554990920\" d=\"390\" c=\"0.18\">mama</w> <w s=\"1583554991770\" d=\"270\" c=\"0.27\"><evHL>poll</evHL></w> </phr>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}