using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^<>]*((<\/?(w|phr|evHL)[^<>]*>)*([^<>]*))*$";
string input = @"toto<phr start=""1583554989500"" end=""1583554992040"" confidence=""0.22""><w s=""1583554989500"" d=""60"" c=""0.22"">Hey</w> <w s=""1583554990920"" d=""390"" c=""0.18"">mama</w> <w s=""1583554991770"" d=""270"" c=""0.27""><evHL>poll</evHL></w> </phr>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}