# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\>)(\n+)|(\n+)(?=\<)//g;t' <<< "<all-tags
with-their=\"attribute\"
even-if-there=\"are-more\"
aa=\"1\">
and all the content between
the start and end tag
</all-tags>
<meta-tag />"