use strict;
my $str = '<all-tags
with-their="attribute"
even-if-there="are-more"
aa="1">
and all the content between
the start and end tag
</all-tags>
<meta-tag />';
my $regex = qr/(?<=\>)(\n+)|(\n+)(?=\<)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";