#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<=\>)(\n+)|(\n+)(?=\<)"
Local $sString = "<all-tags " & @CRLF & _
" with-their="attribute"" & @CRLF & _
"" & @CRLF & _
" even-if-there="are-more"" & @CRLF & _
"aa="1">" & @CRLF & _
"and all the content between" & @CRLF & _
" the start and end tag" & @CRLF & _
"</all-tags>" & @CRLF & _
"<meta-tag />"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)