# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\>)(\n+)|(\n+)(?=\<)"
test_str = ("<all-tags \n"
" with-their=\"attribute\"\n\n"
" even-if-there=\"are-more\"\n"
"aa=\"1\">\n"
"and all the content between\n"
" the start and end tag\n"
"</all-tags>\n"
"<meta-tag />")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.