import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\>)(\\n+)|(\\n+)(?=\\<)";
final String string = "<all-tags \n"
+ " with-their=\"attribute\"\n\n"
+ " even-if-there=\"are-more\"\n"
+ "aa=\"1\">\n"
+ "and all the content between\n"
+ " the start and end tag\n"
+ "</all-tags>\n"
+ "<meta-tag />";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}