re = /(?<=\>)(\n+)|(\n+)(?=\<)/
str = '<all-tags
with-their="attribute"
even-if-there="are-more"
aa="1">
and all the content between
the start and end tag
</all-tags>
<meta-tag />'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result