#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<a1>PREM)\|(?<a2>.{4})\|(?<a3>.{2})\|(?<a4>.{2})\|(?<a5>.+)"
Local $sString = "PREM|E001|E5|RG|ACCOUNTSPAYABLE@THMGT.COM"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")