$re = '/(?<a1>PREM)\|(?<a2>.{4})\|(?<a3>.{2})\|(?<a4>.{2})\|(?<a5>.+)/';
$str = 'PREM|E001|E5|RG|ACCOUNTSPAYABLE@THMGT.COM';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);