using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<a1>PREM)\|(?<a2>.{4})\|(?<a3>.{2})\|(?<a4>.{2})\|(?<a5>.+)";
string input = @"PREM|E001|E5|RG|ACCOUNTSPAYABLE@THMGT.COM";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}