const regex = /(?<a1>PREM)\|(?<a2>.{4})\|(?<a3>.{2})\|(?<a4>.{2})\|(?<a5>.+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<a1>PREM)\\|(?<a2>.{4})\\|(?<a3>.{2})\\|(?<a4>.{2})\\|(?<a5>.+)', '')
const str = `PREM|E001|E5|RG|ACCOUNTSPAYABLE@THMGT.COM`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}