// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?<a1>PREM)\|(?<a2>.{4})\|(?<a3>.{2})\|(?<a4>.{2})\|(?<a5>.+)").unwrap();
let string = "PREM|E001|E5|RG|ACCOUNTSPAYABLE@THMGT.COM";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}