use strict;
my $str = 'password = potato123! found, is ok
$dbpass= train123; = found, is ok
pass:function($pass); = not found, is ok
$dbpassword= function(\'dontfindme\'); = found, should not be found
';
my $regex = qr/(?:pass|password)\s*[:=;,]\s*(?!\s{0,}function)(\S*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}