import re
regex = re.compile(r"(?:pass|password)\s*[:=;,]\s*(?!\s{0,}function)(\S*)")
test_str = ("password = potato123! found, is ok\n"
"$dbpass= train123; = found, is ok\n"
"pass:function($pass); = not found, is ok\n"
"$dbpassword= function('dontfindme'); = found, should not be found\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")