re = /(?:pass|password)\s*[:=;,]\s*(?!\s{0,}function)(\S*)/
str = 'password = potato123! found, is ok
$dbpass= train123; = found, is ok
pass:function($pass); = not found, is ok
$dbpassword= function(\'dontfindme\'); = found, should not be found
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end