#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https?\:\/\/(localhost|127\.0\.0\.1|0\.0\.0\.0|\:\:1).*"
Local $sString = "http://localhost:3000/fixtures" & @CRLF & _
"https://localhost:3000/fixtures" & @CRLF & _
"http://127.0.0.1:3000/fixtures" & @CRLF & _
"http://127.0.0.1:3000/fixtures" & @CRLF & _
"http://localhost:8000/fixtures" & @CRLF & _
"https://localhost:8000/fixtures" & @CRLF & _
"http://127.0.0.1:8000/fixtures" & @CRLF & _
"http://localhost/fixtures" & @CRLF & _
"https://localhost/fixtures" & @CRLF & _
"http://127.0.0.1/fixtures" & @CRLF & _
"https://127.0.0.1/fixtures" & @CRLF & _
"http://::1/fixtures" & @CRLF & _
"https://::1/fixtures" & @CRLF & _
"http://::1:8000/fixtures" & @CRLF & _
"https://::1:5000/fixtures" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")