using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?\:\/\/(localhost|127\.0\.0\.1|0\.0\.0\.0|\:\:1).*";
string input = @"http://localhost:3000/fixtures
https://localhost:3000/fixtures
http://127.0.0.1:3000/fixtures
http://127.0.0.1:3000/fixtures
http://localhost:8000/fixtures
https://localhost:8000/fixtures
http://127.0.0.1:8000/fixtures
http://localhost/fixtures
https://localhost/fixtures
http://127.0.0.1/fixtures
https://127.0.0.1/fixtures
http://::1/fixtures
https://::1/fixtures
http://::1:8000/fixtures
https://::1:5000/fixtures
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}