import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?\\:\\/\\/(localhost|127\\.0\\.0\\.1|0\\.0\\.0\\.0|\\:\\:1).*";
final String string = "http://localhost:3000/fixtures\n"
+ "https://localhost:3000/fixtures\n"
+ "http://127.0.0.1:3000/fixtures\n"
+ "http://127.0.0.1:3000/fixtures\n"
+ "http://localhost:8000/fixtures\n"
+ "https://localhost:8000/fixtures\n"
+ "http://127.0.0.1:8000/fixtures\n"
+ "http://localhost/fixtures\n"
+ "https://localhost/fixtures\n"
+ "http://127.0.0.1/fixtures\n"
+ "https://127.0.0.1/fixtures\n"
+ "http://::1/fixtures\n"
+ "https://::1/fixtures\n"
+ "http://::1:8000/fixtures\n"
+ "https://::1:5000/fixtures\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}