use strict;
my $str = 'http://localhost:3000/fixtures
https://localhost:3000/fixtures
http://127.0.0.1:3000/fixtures
http://127.0.0.1:3000/fixtures
http://localhost:8000/fixtures
https://localhost:8000/fixtures
http://127.0.0.1:8000/fixtures
http://localhost/fixtures
https://localhost/fixtures
http://127.0.0.1/fixtures
https://127.0.0.1/fixtures
http://::1/fixtures
https://::1/fixtures
http://::1:8000/fixtures
https://::1:5000/fixtures
';
my $regex = qr/https?\:\/\/(localhost|127\.0\.0\.1|0\.0\.0\.0|\:\:1).*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}