package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https?\:\/\/(localhost|127\.0\.0\.1|0\.0\.0\.0|\:\:1).*`)
var str = `http://localhost:3000/fixtures
https://localhost:3000/fixtures
http://127.0.0.1:3000/fixtures
http://127.0.0.1:3000/fixtures
http://localhost:8000/fixtures
https://localhost:8000/fixtures
http://127.0.0.1:8000/fixtures
http://localhost/fixtures
https://localhost/fixtures
http://127.0.0.1/fixtures
https://127.0.0.1/fixtures
http://::1/fixtures
https://::1/fixtures
http://::1:8000/fixtures
https://::1:5000/fixtures
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}