const regex = /https?\:\/\/(localhost|127\.0\.0\.1|0\.0\.0\.0|\:\:1).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https?\\:\\\/\\\/(localhost|127\\.0\\.0\\.1|0\\.0\\.0\\.0|\\:\\:1).*', 'gm')
const str = `http://localhost:3000/fixtures
https://localhost:3000/fixtures
http://127.0.0.1:3000/fixtures
http://127.0.0.1:3000/fixtures
http://localhost:8000/fixtures
https://localhost:8000/fixtures
http://127.0.0.1:8000/fixtures
http://localhost/fixtures
https://localhost/fixtures
http://127.0.0.1/fixtures
https://127.0.0.1/fixtures
http://::1/fixtures
https://::1/fixtures
http://::1:8000/fixtures
https://::1:5000/fixtures
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}