using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*(?:\+?(\d{1,3})\s*)?(\s?\(?\d{2}\)\s?)?(\s?[-. (]*(\d{3})[-. )]*)?((\d{3,4})[-. ]*(\d{2,5})(?:[-.x ]*(\d+))?)\s*$";
string input = @"011 1 703 111 1234";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}