const regex = new RegExp('^\\s*(?:\\+?(\\d{1,3})\\s*)?(\\s?\\(?\\d{2}\\)\\s?)?(\\s?[-. (]*(\\d{3})[-. )]*)?((\\d{3,4})[-. ]*(\\d{2,5})(?:[-.x ]*(\\d+))?)\\s*$', 'gm')
const str = `011 1 703 111 1234`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}