use strict;
my $str = '011 1 703 111 1234';
my $regex = qr/^\s*(?:\+?(\d{1,3})\s*)?(\s?\(?\d{2}\)\s?)?(\s?[-. (]*(\d{3})[-. )]*)?((\d{3,4})[-. ]*(\d{2,5})(?:[-.x ]*(\d+))?)\s*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}