re = /^\s*(?:\+?(\d{1,3})\s*)?(\s?\(?\d{2}\)\s?)?(\s?[-. (]*(\d{3})[-. )]*)?((\d{3,4})[-. ]*(\d{2,5})(?:[-.x ]*(\d+))?)\s*$/m
str = '011 1 703 111 1234'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end