import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(?:\\+?(\\d{1,3})\\s*)?(\\s?\\(?\\d{2}\\)\\s?)?(\\s?[-. (]*(\\d{3})[-. )]*)?((\\d{3,4})[-. ]*(\\d{2,5})(?:[-.x ]*(\\d+))?)\\s*$";
final String string = "011 1 703 111 1234";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}