# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:(?!.*b)(?<pre1>.*)|(?<pre2>.*)(b(?!c))(?<post>.*))$/$<pre1>$<pre2>$<post>bc/gm;t' <<< "abcd
abd
ad"