re = /^(?:(?!.*b)(?<pre1>.*)|(?<pre2>.*)(b(?!c))(?<post>.*))$/m
str = 'abcd
abd
ad'
subst = '$<pre1>$<pre2>$<post>bc'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result