import Foundation
let pattern = #"^(?:(?!.*b)(?<pre1>.*)|(?<pre2>.*)(b(?!c))(?<post>.*))$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
abcd
abd
ad
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$<pre1>$<pre2>$<post>bc"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)