use strict;
my $str = 'abcd
abd
ad';
my $regex = qr/^(?:(?!.*b)(?<pre1>.*)|(?<pre2>.*)(b(?!c))(?<post>.*))$/mp;
my $subst = '$<pre1>$<pre2>$<post>bc';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";