const regex = /^(?:(?!.*b)(?<pre1>.*)|(?<pre2>.*)(b(?!c))(?<post>.*))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?!.*b)(?<pre1>.*)|(?<pre2>.*)(b(?!c))(?<post>.*))$', 'gm')
const str = `abcd
abd
ad`;
const subst = `$<pre1>$<pre2>$<post>bc`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);