using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""tg:\/\/resolve\?domain=([\w\d_]+)""";
string input = @"<a href=""tg://resolve?domain=Moron21Centuriesbot"" class=""tl_main_download_btn"">Ссылка</a>,
<a href=""tg://resolve?domain=Moron22bot"" class=""tl_main_download_btn"">Ссылка</a>,
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}